How I dramatically improved the stability of my internet connection


Rickyk

Well-Known Member
Veteran
Jan 18, 2007
1,141
298
171
@kvikram
Sorry for the OT, but are you using BSNL in Gurgaon? If so, can you plz do me a favour and ping/traceroute to this IP - 216.12.220.165.

The above IP is for the Quake Live Server based in Singapore. I am fed up of my current ISP (Reliance) because their routing changes 4 times a day and want to switch to another ISP.
If anyone using Airtel in Gurgaon can also ping that IP and post here it would be greatly appreciated.
Thanks in advance..
 

prateekS

Well-Known Member
Veteran
Sep 19, 2012
2,544
426
128
27
Mumbai
Oh then it's fine.. But the MTNL server room guy did say it's high.

Internet works fine but 40+ is considered a high value.

Have been using G. Dmt since a year..
 

madhuraj

Active Member
Disciple
Jan 7, 2009
118
17
31
I am using MTNL wifi at home.. and the connection re-establishes a few times.. will this G.Dmt work in my case??
 

6pack

Well-Known Member
ex-Mod
Sep 19, 2005
7,761
1,695
302
This setting is only for modems. If your wifi router has an inbuilt modem in it, it should be under some modulation settings.
Wifi routers without dial up modem in them don't have such settings since they get internet from wan port.
 
  • Like
Reactions: asingh

swapyworld

Well-Known Member
Adept
Sep 16, 2009
390
11
82
Mumbai
It's one of the things suggested if you call MTNL 1504 service !!
For me, it didn't work, had to change the line itself to get the stable connection!!

btw any ways to reduce the ping time?
 

Silent_Audience

New Member
Recruit
May 20, 2014
1
0
1
I think the below mentioned link is relevant for this thread

http://www.punjab.bsnl.co.in/bandhan_bb1.htm

This is article from BSNL Punjab circle mentioning the step for getting better speed for BSNL Broadband subscriber. This is applicable to all BSNL Broadband subscriber irrespective of their Circle. In the article the one of the most important step is Step 16

16. Use Proper Modulation:
If the distance of the subscriber's modem is more than 2.5 Kms of length from the Telephone Exchange (DSLAM) then Use only G.dmt Modulation in the modem DSL settings. Disable all other modulations if possible. The distance of underground cable from Exchange to the user Home is considered rather than road or aerial distance.
The another useful is Step 1

1. For Reliability & Speed, Use following DNS Addresses:
A) On Dial-up or Bridge mode Broadband connections.
Enter following DNS address at Local Area Connection or Wireless Network Connection.

Primary DNS -- 192.168.1.1 (Filling this IP will automatically takes first DNS server from BSNL)
Alternate DNS -- 156.154.70.1 or 156.154.71.1 or 4.2.2.2 or 208.67.222.222 or 208.67.220.220 or 8.8.4.4 or 8.8.8.8 (Use any of these)

B) Automatic or Multiuser or PPPoE mode Broadband connection.
Login inside the Modem or Router Interface and enter the following DNS address
Primary DNS -- 156.154.70.1 or 156.154.71.1 or 4.2.2.2 or 208.67.222.222 or 208.67.220.220 or 8.8.4.4 or 8.8.8.8 (Use any of these)
Alternate DNS -- 156.154.70.1 or 156.154.71.1 or 4.2.2.2 or 208.67.222.222 or 208.67.220.220 or 8.8.4.4 or 8.8.8.8 (Use any of these but different from Primary DNS).
Generally BSNL provided DNS is heavily loaded and response is slow. Due to that DNS resolution for any webpage takes time which finally result slow loading of that webpage. It is better to use Google DNS. Changing the DNS server may not always be possible on BSNL provided modem. You can follow the below mentioned link to change it on your Laptop/PC. After That functionality will be same.

http://www.intechgrity.com/speed-up-bsnl-broadband-using-google-dns-open-dns/#

The final is Configuring the MTU on PPPoE Mode. Though this article is mentioning

4. Choose Right MTU Size (Maximum Transmission Unit):
Almost all MTU sizes (like 1500, 1492 or 1480) give good speed performance among all website browsing & downloading. But one should preferably use 1492 as MTU in all Modem/Router connections until & unless one faces any significant problem with MTU. The value is defined inside the Modem or Router configuration page.
Still I will recommend to set MTU in any single value between the range of 1430 to 1450 for PPPoE.

I hope that following those steps this you might get better BSNL Broadband speed. :)
 

aman.pitbull

Well-Known Member
Adept
Feb 10, 2007
1,237
120
153
Navi Mumbai
My connection has been On since yesterday 5 PM and it was on entire night also. I believe it never disconnected anytime (cannot confirm but i feel).
Currently the stats of my MTNL modem show this..


DownstreamUpstream
SNR Margin (dB):6.2 6.3
Attenuation (dB):34.5 20.5
Output Power (dBm):12.4 17.2
Attainable Rate (Kbps):1704 889
Rate (Kbps):923 893
Your SNR margin is low. Attenuation values are good if not excellent output power is a bit liw for downstream settings.

Overall your connection seems to be better than average of what MTNL offers.
 

flash23

Active Member
Adept
Jan 3, 2011
400
25
41
Pune
Your line stats are awesome, you should get a stable connection.
BSNL has very strong roots in my area. The exchage is about a km far.
I havent faced any downtime more than 5 to 10 minutes, that too only once or twice, in the 5 years that I have this connection.
 

kvikram

Well-Known Member
Adept
Nov 16, 2010
1,126
107
103
26
A month before I switched to a TP-LINK modem which had the G.DMT option, and it worked great for some time. Then I got a weird issue where the DSL light would become unstable. Normally, before I switched to G.DMT, it was the internet light which was unstable while the DSL light would always be rock-solid. I automatically assumed that it was some kind of problem with the line, and pestered the ISP to no avail.

Turns out it was a mistake on my part. While on most modems, the default MTU value is 1492 (which is what works for BSNL), the MTU value on my modem was 1480, which was the default. I changed it to 1492 this afternoon and so far it has been super-stable. Let's see how it goes. :)
 

aman.pitbull

Well-Known Member
Adept
Feb 10, 2007
1,237
120
153
Navi Mumbai
I'm using the TP-LINK TD-8816 modem with my MTNL connection and was configured to use ADSL2+ Modulation by default and was working good for the past 1.5 year. From the past 3 months, the modem started resetting a LOT, due to weak signal from the ISP (MTNL). The modem tries to reconnect every time the connection is lost (due to weak signal), but when it tries to reconnect it keeps on restarting until the signal condition improves. Sometimes, it does start and gets a stable connection, after repeating the "turning on and off" cycle continuously for 20-30mins, and if the signal gets weak again, it starts the same loop again.

I've found that this problem can be sorted out by using a better quality Power Supply (pure DC, 5V, 2A supply). I think, the power supply that came with TD-8816 has gone bad (aged), I will send it for RMA.

There's another issue, a major one I think. My ISPs (MTNL) exchange is far off (>3KMs from my modem). According to the OP, G.DMT gives less net-Bandwidth but greater line stability and lesser attenuation. But when I set ADSL Mode to G.DMT, it still connects automatically using the ADSL2+ modulation. Please look at the following two screenshots of the setting and the modem statistics:

https://drive.google.com/file/d/0B_WZsj9AAGZKMXkyc1dnLUlIVEU/edit?usp=sharing

https://drive.google.com/file/d/0B_WZsj9AAGZKWmswUUZvRlhLUVU/edit?usp=sharing

Please suggest what is wrong here, apart from the ISP giving a bad signal-line quality.
 

kvikram

Well-Known Member
Adept
Nov 16, 2010
1,126
107
103
26
@aman.pitbull That's really odd. I have a TP-LINK modem too and it connects using G.DMT as it should. Why don't you try the G.DMT setting using another modem and see if the problem still persists?