Peculiar issue with my router(?) TP link AC2300.


deezcnuts

Member
Disciple
May 30, 2020
28
9
6
I am having a bit of a weird issue with my TP link AC2300 router(maybe something else?).

When I am on 2.4ghz wifi, I am unable to access my raspberry pi by using hostname. Always have to type the full ip address. It does have a static lan ip set on the router. This issue appears on connecting to ssh, accessing pihole and homebridge dashboard or webmin management page. Always have to use the full ip and port.

But if I connect to 5ghz wifi, I am able to connect using the hostname set on the router. Both - 'raspberrypi:port' and 'pi.hole' work.
Using 'ssh pi@raspberrypi' in terminal only works on 5ghz. Otherwise, on 2.4ghz, I have to use full address 'ssh pi@192.168.x.x'

This issue happens on my phone and my macbook and another laptop on wifi. Haven't checked using ethernet connection.

Not a big issue but still an annoyance. Any tips?
 

CA50

Well-Known Member
Adept
Dec 26, 2009
3,392
70
137
GraveYard
Have you added the router IP as the DNS server for the 5 GHz network and not for the 2.4 GHz network?
 

deezcnuts

Member
Disciple
May 30, 2020
28
9
6
Have you added the router IP as the DNS server for the 5 GHz network and not for the 2.4 GHz network?
Afaik, there is only one place for dns settings. Couldn't find it seperately under each WiFi bands. The DNS ip setting is my raspberrypi lan ip for adblocking by pihole.