CPU/Mobo RAM speed incorrect


deepakvrao

Well-Known Member
Adept
May 2, 2008
585
56
117
Hi Guys,

My RAM is DDR4 3200, but it shows as 2666. When I checked the BIOS this is what I got. The second picture shows what I 'plan to do', but needed to check that it is the right thing? In other words, should I just change that setting from 'auto' to DDR4-3200?

Also, why is the board not detecting the RAM speed correctly? Seems this is a common issue?


20191017_092811.jpg
20191017_092831.jpg
 

SunnyBoi

Well-Known Member
Veteran
Jan 31, 2005
4,402
278
172
33
Bangalore
www.funenclave.com
As Vishal said, you need to enable XMP and choose a profile. For example my RAM has 2 XMP profiles, one for 2933 and another for 3200. I simply chose 3200 , saved BIOS and rebooted without problems

In your case just enable XMP, set the speed at 3200? Boot into windows and check with CPU-Z if the right profile has been selected
 

deepakvrao

Well-Known Member
Adept
May 2, 2008
585
56
117
Thanks guys. It worked.
Post automatically merged:

Also, if I am using 2 of the 4 slots, which should I use?
 
Last edited:

deepakvrao

Well-Known Member
Adept
May 2, 2008
585
56
117
It will be
Screenshot_2.png
clearly mentioned in the motherboard manual which slots to use
Thanks. Seems to be alternate slots,, which I had read. Will it make any difference whether I put it in slots 1 & 3 or slots 2 & 4?
 

SunnyBoi

Well-Known Member
Veteran
Jan 31, 2005
4,402
278
172
33
Bangalore
www.funenclave.com
Thanks. Seems to be alternate slots,, which I had read. Will it make any difference whether I put it in slots 1 & 3 or slots 2 & 4?
Its good practice to install ram on the slots farthest from socket for each channel like below. On my motherboard manual, it is recommended to install only in this config, not A1 B1. People have had problems getting rated ram speeds if they install in A1 B1 on my motherboard (MSI B450 Tomahawk)

 
  • Like
Reactions: deepakvrao