Sony receiver in protect mode


leap

Member
Disciple
Mar 14, 2015
5
4
6
Hello, my sony receiver sony str k-1000p goes into protect mode and then turns off. I called sony service centre and they told it's not repairable due to old model.ive also shown to couple of local technicians but no help. Is there anyone here who can help me get it repaired? sorry for my bad english. Thanks
 

vishal_k

Member
Disciple
Jun 3, 2012
53
6
22
Chhattisgarh
Hello, my sony receiver sony str k-1000p goes into protect mode and then turns off. I called sony service centre and they told it's not repairable due to old model.ive also shown to couple of local technicians but no help. Is there anyone here who can help me get it repaired? sorry for my bad english. Thanks
Have you tried disconnecting everything before turning it on? Sometimes a damaged speaker cable puts the receiver in protection mode.
 
  • Like
Reactions: leap

Nitendra Singh

Member
Disciple
Jan 12, 2018
8
7
6
Similar problem happened with my Home theater receiver DAV DZ570.
basic troubleshooting is checking all the connectors and cables for speakers, may be a damaged speaker connecting port or faulty speaker cable.
Try connecting 1 speaker at a time.
you can also look fof if there's dust or excessive heating.
If nothing happens , Unscrew the Receiver - you can try cleaning the IC's on PCB using a pait brush, see if it works.
If nothing happens - there's a major problem - One or more IC is damaged on the PCB. it may be any channel like front L, front R, center, rear L, rear R or subwoofer.
then in this case it's really difficult to find similar IC from a similar model.
then in worst case you can bypass this error by soldering a thin cable (refer to youtube videos as suggested in above comment or search for more youtube videos for your specific model)
but after doing this all, your one of the speakers won't works whose IC is faulty.
Same thing happened mine front left channel is gone but other all speakers works after this method.
 
  • Like
Reactions: leap