Storage Solutions WD Elements 2TB Stopped Working


Altair

Well-Known Member
Section Mod
Nov 28, 2010
1,957
38
62
27
Chandigarh
I have a 2TB WD Elements External 2.5" HDD which stopped working suddenly this morning.
There no click sounds or anything. It is not getting detected in my computer but it is being detected in Disk Management and gives the following error.
I still have a warranty of 70 days remaining on the HDD.
But if possible i want to know if there is any other way to make this drive working.

@vivek.krishnan Hey man please give some advice. @Black_Hawk recommended your name. Please help me out.

I get this in the Disk Management:

Disk Error.jpg


If I do go to the next step I get this error:

Disk Error2.jpg



Is the USB Port faulty here?
Also I think I have lost the bill. Will WD Still RMA my HDD?
 

ch@ts

Well-Known Member
Veteran
Jun 13, 2005
1,171
218
152
Check the cables, both USB and the one from the adapter.
 

JaredDM

Member
Disciple
Mar 16, 2016
31
9
11
37
Providence, RI
www.data-medics.com
If it's being recognized like that, it's not likely to be a USB cable issue. Most likely it's bad sectors in the partition table or file system preventing it from mounting.

Unless you need data recovered, I'd just RMA it.
 

Altair

Well-Known Member
Section Mod
Nov 28, 2010
1,957
38
62
27
Chandigarh
Hey guys, thanks for the replies. The Data was not that important to me so I sent it for the RMA and got a new HDD as a replacement 2 days ago. Apologies for the delayed reply.
Thanks everyone.
 
  • Like
Reactions: Black_Hawk