Nokia G-140W-F bridge mode?

Anyone had a luck bridging Nokia g-140w successfully? @rajil.s

Okay, so @tellanand bro. I have done the exact settings like you but it is not working. I have seen your screenshots as well.
Lets skip the Openwrt setup, first I tried to set this up on Windows 8.1 through PPPoe dialer just like you set.

1. I have set Nokia router just like yours. (Delete Wan setting, Same LAN IP's infact etc) and connected LAN from LAN4 to directly my Laptop ethernet port.
2. I have set VLAN to 100 which was in my Nokia router in Network Adapter settings of Windows computer.
3. Created Broadband PPPoe connection and tried connecting but encountered Error 651.
Also I have made the Mac address same so that isn't a issue.

@arjun2022 - Without knowing any details of your configuration and settings, my guess is, something is wrong with your windows VLAN settings. I'd suggest you use wireshark (network sniffer) to sniff packets on interface VLAN100 on your PC and check if there is any traffic at all. That'll tell you some clues.

Some of my examinations:
1. When I connect LAN to my laptop, I do not set any ipv4 settings and it automatically assigns 169.x.x.x IP. It doesn't receive any incoming packets as well. How does it work to you when you plug the LAN to windows? What IP it shows to you?

That's the right thing to do (i.e. do not set any IPv4 address; leave it to obtain it automatically through DHCP). One of the reasons Windows would assign a 169.x.x.x IP address is because its unable to attain an IP address using DHCP (b'coz your PPPoE session isn't established and successful). Also make sure you are doing this on the correct Ethernet interface (which has VLAN100) - because when you create a VLAN on the PC, it'll create another Ethernet interface for VLAN100. If possible please copy and paste the output of "ipconfig /all" (from cmd prompt) on Windows here. I can take a look at it and review it for any issues.

2. Then after inserting LAN, I dial PPPoe on windows and it gives Error 651. But it also gives the same Error 651 when I do not even plug the LAN cable into my laptop?

I googled for Error 651 and that seems to be a "Modem Error" whatever that means - hence my suspect on the Windows VLAN settings or WIndows driver support. Sniffing network traffic will give you more clues, IMHO.

Also, @tellanand bro, I see you have sent LAN settings screenshots of Nokia router, could you please send the same Pages of WAN? WAN under Network and WAN under status. This is very important.

The reason I did not post the WAN config, is because there is nothing to post; like I said, I deleted the WAN config. To give you peace, I've attached it here anyways :) - my WAN page only has VoIP configuration.


Nokia-WAN Config.png
Nokia-WAN Config1.png


Good luck!
Post automatically merged:

Wow............
That was absolutely brilliant. I started from step 4, .....
Thanks a million for sharing this @tellanand .
I dont know how to thank you enough.

This is fantastic. Very happy for you, @ajeesh_m !!

Hope others can get it to work soon, as well! Happy to help!
 
Last edited:
I can confirm the process @tellanand described worked for me in Delhi. I recently added Airtel as my second ISP connection in addition to ACT and they gave me Nokia G-140W-F. I am using port 4 only on the Nokia Router in bridge mode, other ports are untouched. I followed following steps outlined by @tellanand and it worked in first attempt. I am using Ubiquiti USG at home and doing Active-Failover over two ISP links links now

0. Login to the web interface of the Airtel's Nokia ONT device
1. Backup your configuration by navigating to Maintenance-->Backup and Restore-->Export Config File;
1a. This will be useful in case you mess up stuff in your configuration and want to restore things back.
2. Navigate to "Network-->WAN"; delete "?_TR069_INTERNET_R_VID_100" entry.
3. Navigate to "Network-->LAN"; Setup one of the LAN ports to "Bridge Mode"; you can configure all of them to "Bridge Mode" as well - your choice; the Nokia device will reboot at this point for the changes to take effect.
3a. The LAN port you set to "Bridge Mode" should be the port you want to connect your downstream home router (where you run the PPPoE authentication).
4. Configure your downstream home router with the ISP's PPPoE username and password.
5. Airtel's Nokia modem bridges the PPPoE packets from the PON interface to the selected Ethernet LAN port on "VLAN 100" (yes, that's correct; I figured this out the hard way - it doesn't strip off the vlan headers before bridging it to the LAN port; neither does it support any option to strip the VLAN headers before bridging). So you need to configure your downstream home router's port on VLAN 100. If your home router does not support VLANs then, BUMMER, you cannot use bridge mode! :banghead: (shame on Airtel & Nokia :mad: to have overlooked this important aspect - b'coz a lot of home routers do NOT support VLANs; fortunately mine does, because I use OpenWRT firmware).
6. Configure your downstream home router's WAN port (that connects to the Nokia router) on VLAN 100 (tagged; not untagged)
7. That's it. Your PPPoE authentication should go through and your internet link should be UP and running.


Code:
interfaces {
    ethernet eth0 {
        description WAN
        vif 100 {
            description WAN
            firewall {
                in {
                    ipv6-name WANv6_IN
                    name WAN_IN
                }
                local {
                    ipv6-name WANv6_LOCAL
                    name WAN_LOCAL
                }
                out {
                    ipv6-name WANv6_OUT
                    name WAN_OUT
                }
            }
            pppoe 2 {
                default-route none
                firewall {
                    in {
                        ipv6-name WANv6_IN
                        name WAN_IN
                    }
                    local {
                        ipv6-name WANv6_LOCAL
                        name WAN_LOCAL
                    }
                    out {
                        ipv6-name WANv6_OUT
                        name WAN_OUT
                    }
                }
                name-server none
                password ****************
                user-id username@airtelbroadband.in
            }
        }
    }
    ethernet eth1 {
        address 192.168.55.1/26
        description LAN
        firewall {
            in {
                ipv6-name LANv6_IN
                modify LOAD_BALANCE
                name LAN_IN
            }
            local {
                ipv6-name LANv6_LOCAL
                name LAN_LOCAL
            }
            out {
                ipv6-name LANv6_OUT
                name LAN_OUT
            }
        }
        vif 10 {
            address 192.168.10.1/25
            firewall {
                in {
                    ipv6-name GUESTv6_IN
                    modify LOAD_BALANCE
                    name GUEST_IN
                }
                local {
                    ipv6-name GUESTv6_LOCAL
                    name GUEST_LOCAL
                }
                out {
                    ipv6-name GUESTv6_OUT
                    name GUEST_OUT
                }
            }
        }
        vif 20 {
            address 192.168.20.1/25
            firewall {
                in {
                    ipv6-name LANv6_IN
                    modify LOAD_BALANCE
                    name LAN_IN
                }
                local {
                    ipv6-name LANv6_LOCAL
                    name LAN_LOCAL
                }
                out {
                    ipv6-name LANv6_OUT
                    name LAN_OUT
                }
            }
        }
    }
    ethernet eth2 {
        description WAN2
        firewall {
            in {
                ipv6-name WANv6_IN
                name WAN_IN
            }
            local {
                ipv6-name WANv6_LOCAL
                name WAN_LOCAL
            }
            out {
                ipv6-name WANv6_OUT
                name WAN_OUT
            }
        }
        pppoe 1 {
            default-route none
            firewall {
                in {
                    ipv6-name WANv6_IN
                    name WAN_IN
                }
                local {
                    ipv6-name WANv6_LOCAL
                    name WAN_LOCAL
                }
                out {
                    ipv6-name WANv6_OUT
                    name WAN_OUT
                }
            }
            name-server none
            password ****************
            user-id user-id
        }
    }
    loopback lo {
    }
}
load-balance {
    group wan_failover {
        interface pppoe1 {
            failover-only
            route-test {
                initial-delay 20
                interval 10
                type {
                    ping {
                        target 8.8.4.4
                    }
                }
            }
        }
        interface pppoe2 {
            route-test {
                initial-delay 20
                interval 10
                type {
                    ping {
                        target 8.8.4.4
                    }
                }
            }
        }
        sticky {
            dest-addr enable
            dest-port enable
            source-addr enable
        }
        transition-script /config/scripts/wan-event-report.sh
    }
}
 
2. Navigate to "Network-->WAN"; delete "?_TR069_INTERNET_R_VID_100" entry.

How were you able to edit this? on my Nokia G2425 router the whole WAN page is disabled and cannot make any changes.

Here are more details : https://broadbandforum.co/t/207947/post-1508966

Code:
root@OpenWrt:~# vi /etc/config/network
config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option mtu '1506'
        option ipaddr '192.168.31.1'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '*****'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option ipv6 'auto'
        option username '******'
        option password '*******'
        option delegate '0'
        option mtu '1506'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 3 2'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 1'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '1t'
        option vid '100'

@tellanand my config file if that helps
 
Last edited:
Found on different forume



So, I finally found the solution to this.

Apparently, only Lan port 4 of the router Nokia G-140W-C can do bridging mode. All the other ports can't.

I have done the change and it's working for me now. Finally, I can use my Asus router for everything, and Nokia router just for termination.

Please try, I am sure it should work for everyone.

The changes you need to do on the Nokia router are just 2:

1. Change the Lan port 4 to bridge mode (it will need a restart)
2. Enable IPoe mode in WAN settings. (Just restart after this to be on the safe side, though it doesn't need a restart)

Happy bridging and please don't forget to upvote if it works for you
is there any issue if change the PPPoE to IPoE will i loose the PPPoE password that is already set there...
Meaning if anything goes wrong can i go back to PPPoE without any issues considering i may not have the password.
 
@arjun2022 - someone on anther forum posted this. Check it out: https://broadbandforum.co/t/170222/post-1463562

Only Airtel backend can help you to bridge!
Hi @arjun2022 did you manage to get it to work? I am not from india but I have been given huawei EG8145V5 as my ONT device and just like you I'm struggling set it to work in L2 Bridge mode. I can set my ONT to work in "Bridge WAN mode" bound to a LAN port where I connect a linux box that I use for routing however in this mode the ONT device is still tagging the upstream traffic with the configured VLAN. I would like for the tagging to be done on my Linux box. I have tried settings one of my LAN ports in L2 Bridge mode and remove the "TR069_INTERNET_R_VID_10" connection, however all traffic received on this L2-bridged port is never forwarded out the PON port to the upstream ISP. I have confirmed by sniffing the traffic forwarded out the PON port with tcpdump, no matter what traffic is received on the bridged LAN port it is never sent out upstream so I suspect there's some kind of binding that is done in the ISP's backend that needs to be reconfigured in order to be able to set the ONT in full transparent L2 bridge mode.
 
I had the same issue and I figured out how to solve it. I have Airtel Nokia modem G-140W-F.

Here's what I did:

0. Login to the web interface of the Airtel's Nokia ONT device
1. Backup your configuration by navigating to Maintenance-->Backup and Restore-->Export Config File;
1a. This will be useful in case you mess up stuff in your configuration and want to restore things back.
2. Navigate to "Network-->WAN"; delete "?_TR069_INTERNET_R_VID_100" entry.
3. Navigate to "Network-->LAN"; Setup one of the LAN ports to "Bridge Mode"; you can configure all of them to "Bridge Mode" as well - your choice; the Nokia device will reboot at this point for the changes to take effect.
3a. The LAN port you set to "Bridge Mode" should be the port you want to connect your downstream home router (where you run the PPPoE authentication).
4. Configure your downstream home router with the ISP's PPPoE username and password.
5. Airtel's Nokia modem bridges the PPPoE packets from the PON interface to the selected Ethernet LAN port on "VLAN 100" (yes, that's correct; I figured this out the hard way - it doesn't strip off the vlan headers before bridging it to the LAN port; neither does it support any option to strip the VLAN headers before bridging). So you need to configure your downstream home router's port on VLAN 100. If your home router does not support VLANs then, BUMMER, you cannot use bridge mode! :banghead: (shame on Airtel & Nokia :mad: to have overlooked this important aspect - b'coz a lot of home routers do NOT support VLANs; fortunately mine does, because I use OpenWRT firmware).
6. Configure your downstream home router's WAN port (that connects to the Nokia router) on VLAN 100 (tagged; not untagged)
7. That's it. Your PPPoE authentication should go through and your internet link should be UP and running.

Good luck!

- Anand
Does this works on recent Tata nokia routers too?
 
I had the same issue and I figured out how to solve it. I have Airtel Nokia modem G-140W-F.

Here's what I did:

0. Login to the web interface of the Airtel's Nokia ONT device
1. Backup your configuration by navigating to Maintenance-->Backup and Restore-->Export Config File;
1a. This will be useful in case you mess up stuff in your configuration and want to restore things back.
2. Navigate to "Network-->WAN"; delete "?_TR069_INTERNET_R_VID_100" entry.
3. Navigate to "Network-->LAN"; Setup one of the LAN ports to "Bridge Mode"; you can configure all of them to "Bridge Mode" as well - your choice; the Nokia device will reboot at this point for the changes to take effect.
3a. The LAN port you set to "Bridge Mode" should be the port you want to connect your downstream home router (where you run the PPPoE authentication).
4. Configure your downstream home router with the ISP's PPPoE username and password.
5. Airtel's Nokia modem bridges the PPPoE packets from the PON interface to the selected Ethernet LAN port on "VLAN 100" (yes, that's correct; I figured this out the hard way - it doesn't strip off the vlan headers before bridging it to the LAN port; neither does it support any option to strip the VLAN headers before bridging). So you need to configure your downstream home router's port on VLAN 100. If your home router does not support VLANs then, BUMMER, you cannot use bridge mode! :banghead: (shame on Airtel & Nokia :mad: to have overlooked this important aspect - b'coz a lot of home routers do NOT support VLANs; fortunately mine does, because I use OpenWRT firmware).
6. Configure your downstream home router's WAN port (that connects to the Nokia router) on VLAN 100 (tagged; not untagged)
7. That's it. Your PPPoE authentication should go through and your internet link should be UP and running.

Good luck!

- Anand
How to get airtel's pppoe username and password?
 
Back
Top