Storage Solutions 2nd hard disk causing slow boot

tapankunu

Member
Disciple
i recently bought a 1tb internal hard disk from my friend.the problem is that it slows down the boot time which is like 2 minutes.i have windows installed on the ssd which boots my pc within 10 sec when i disconnect the 1tb.the slow boot problem was already in my friend's pc when the 1tb was installed on his pc so i thought it needs a clean.then i took it from him and clean it through command prompt.it works like a new hard disk when transferring files and also no problem with the storage also.but the only problem is that it cause my pc to boot slow. i tried resetting bios and every techniques related to bios but no help. if anyone have the same experience please help me.i forgot to mention that when pc boots it shows the default gigabyte logo for 2 mins and then it starts.if at that time i enter to the bios it shows only the ssd no hdd. after restart when i went to bios at this time bios detects the hdd and also booting is normal so i think 1st time it took 2 mins only to detect the hdd.
 
Last edited:

vishalrao

Global Moral Police
Veteran
if your SSD is also connected via SATA cable try swapping the connections (ordering) and also look in the BIOS of your PC for SATA disk ordering and also disable SMART in BIOS.
 

tapankunu

Member
Disciple
if your SSD is also connected via SATA cable try swapping the connections (ordering) and also look in the BIOS of your PC for SATA disk ordering and also disable SMART in BIOS.
all these already tested.the problem was started in my friend's pc and no change after formatting it in my pc.
 

6pack

Well-Known Member
ex-Mod
maybe that hdd has bad sectors in it and the os is checking it for new bad sectors during boot.
 

tapankunu

Member
Disciple
maybe that hdd has bad sectors in it and the os is checking it for new bad sectors during boot.

when pc boots it shows the default gigabyte logo for 2 mins and then it starts.if at that time i enter to the bios it shows only the ssd no hdd. after restart when i went to bios at this time bios detects the hdd and also booting is normal so i think 1st time it took 2 mins only to detect the hdd.
 

nRiTeCh

Well-Known Member
Veteran
Why not run HD Sentinel and get a clear picture as to whats wrong. Also try running HDtune and do basic scans and if reveals nothing then do thorough scans.
 

nRiTeCh

Well-Known Member
Veteran
when pc boots it shows the default gigabyte logo for 2 mins and then it starts.if at that time i enter to the bios it shows only the ssd no hdd. after restart when i went to bios at this time bios detects the hdd and also booting is normal so i think 1st time it took 2 mins only to detect the hdd.
Its because your boot time disk scan timings are set to either 1min or few seconds where it should actually be 0 seconds wait period.
Also, under bios for hdd select ahci mode manually for each disk.
And also set the boot device priority accordingly.
Disable scan for other boot devices during boot. Some bios had or still got this old setting.
 

tapankunu

Member
Disciple
Its because your boot time disk scan timings are set to either 1min or few seconds where it should actually be 0 seconds wait period.
Also, under bios for hdd select ahci mode manually for each disk.
And also set the boot device priority accordingly.
Disable scan for other boot devices during boot. Some bios had or still got this old setting.
see the settings in the photos attached.which settings i have to change please tell me.
 

Attachments

  • IMG_20190502_132806.jpg
    IMG_20190502_132806.jpg
    281.1 KB · Views: 193
  • IMG_20190502_132834.jpg
    IMG_20190502_132834.jpg
    231.8 KB · Views: 178
  • IMG_20190502_132854.jpg
    IMG_20190502_132854.jpg
    267.4 KB · Views: 154
  • IMG_20190502_131607.jpg
    IMG_20190502_131607.jpg
    180.2 KB · Views: 158
  • IMG_20190502_133052.jpg
    IMG_20190502_133052.jpg
    250 KB · Views: 161
  • IMG_20190502_132918.jpg
    IMG_20190502_132918.jpg
    239.5 KB · Views: 179

tapankunu

Member
Disciple
Its because your boot time disk scan timings are set to either 1min or few seconds where it should actually be 0 seconds wait period.
Also, under bios for hdd select ahci mode manually for each disk.
And also set the boot device priority accordingly.
Disable scan for other boot devices during boot. Some bios had or still got this old setting.
see hd sentinel images.one strange thing is that the hard disk is 3 year old and hd sentinel shows wrong date
 

Attachments

  • 1.JPG
    1.JPG
    123 KB · Views: 176
  • 2.JPG
    2.JPG
    170.1 KB · Views: 164
  • 3.JPG
    3.JPG
    163.4 KB · Views: 183

nRiTeCh

Well-Known Member
Veteran
Disable Full screen logo as you will be able to see whats actually cooking behind.
Boot mode selection: see whats available though default is fine.
Disable Lan pxe boot
Initial display output:
If you have gou select Pcie1 only as usualyl by default igp + pcie is selected.
Sata mode selection: keep ahci or if the setting is ahci + ide or auto, keep auto or both.
Enable Sata hot plug option.[DOUBLEPOST=1556802030][/DOUBLEPOST]Also, it sometimes happens that two drives cause conflicts withing each other due to sharing of common bus so another way is to install first drive in sata 1 and the other in sata 4 port or so on. Try experimenting with various sata slots.

Last way remaining is to update the bios to the latest ver.
 
Last edited:

tapankunu

Member
Disciple
Disable Full screen logo as you will be able to see whats actually cooking behind.
Boot mode selection: see whats available though default is fine.
Disable Lan pxe boot
Initial display output:
If you have gou select Pcie1 only as usualyl by default igp + pcie is selected.
Sata mode selection: keep ahci or if the setting is ahci + ide or auto, keep auto or both.
Enable Sata hot plug option.[DOUBLEPOST=1556802030][/DOUBLEPOST]Also, it sometimes happens that two drives cause conflicts withing each other due to sharing of common bus so another way is to install first drive in sata 1 and the other in sata 4 port or so on. Try experimenting with various sata slots.

Last way remaining is to update the bios to the latest ver.
most of the above techniques already tested.i think i will use it like this forever:grumpy:.anyway thanks for helping:)
 

nRiTeCh

Well-Known Member
Veteran
Well disabling Full screen logo will mostly display where is it getting stuck.
It can also be related to RAMS if you are using sticks with different brands as most mobos don't get well mixing with various brands.
 

tapankunu

Member
Disciple
Well disabling Full screen logo will mostly display where is it getting stuck.
It can also be related to RAMS if you are using sticks with different brands as most mobos don't get well mixing with various brands.
the problem started in my friends pc bro.then i took it from him and the problem still persists.i have 0 issues without the hard disk.previously i had one normal 250gb hdd and my ssd both works well.so no issue from my parts.
 

GPMlore

Well-Known Member
Disciple
Few questions to ask.

1. Did you have any other drive installed in your system before the 1TB?
2. Are you using UEFI or legacy boot?
3. What OS are you using to boot?
 

tapankunu

Member
Disciple
1.no only the 128gb ssd
2.UEFI
3.Windows 10 pro
this problem is happening because of the bios not detecting the hdd properly on 1st boot. when i restart after 1st boot then the bios detects it and the boot time is also asusual.
 

GPMlore

Well-Known Member
Disciple
Your SATA SSD is configured as GPT or MBR?

Here is what I would suggest you to test.

1. Set your boot option 1 to Windows Boot Manager in case it is available, if not then set it to your SSD.
2. Disable boot option 2 - Do not select any other HDD to boot other than your SSD/Windows Boot Manager.
3. Disable CSM support entirely since you are on UEFI.
4. Save and reboot.
 
Top