Storage Solutions Drive MBR went bad in WD My Book. (title edited)


6pack

Well-Known Member
ex-Mod
I have an external WD My Book 3TB usb 3 drive. I tried connecting it to my pc today and it would power on and shut of immediately. I think the pcb inside powering the hdd went bad. So I opened the case and took out the hdd.
It wasa WD Green 3.5inch drive. So thinking I could see drive contents and do some copy/delete work on it, I put the hdd in an external case that supports upto 8TB hdd's (Orico UASP case). The drive starts up properly and hit a sixer on me.
It shows up as empty. Completely. It was 99% full of files.

gparted-wd3TB-3inch.png

gparted-wd3TB-3inch2.png



This is the same behaviour I saw on my 3TB Toshiba drive when I used it in an old external case which did not support more than 2TB hdd's. The Toshiba 3TB works properly in the Orico case. So this one should work too.
I'm hoping the 3TB of data is not lost.
Another thought I have is maybe WD used some kind of encryption on these disks?
Post automatically merged:

It shows up like this in the old external hdd enclosure.

gparted-wd3TB-3inch3.png



Edit: Looks like the MBR got corrupt. I tried Testdisk which found the partition and also showed listing of entire drive with files and folders. I got happy and wrote that partition info to disk thinking it will work.
After writing that partition info I saw that it was still a raw drive and the disk now shows two partitions with different sizes as before. Must be a very dumb unlucky day for me today.
The sizes are 2.5TB as first partition and 500GB as 2nd partition. Looks like testdisk messed up. I'll put off rescuing this hdd for a few years till hdd prices come down a lot.
 
Last edited:

Top