Help required to configure Cisco 861 with Airtel ADSL

Hi. As the topic states am trying to configure the router to use the an Airtel ADSL link.
The existing Beetel modem is configured in bridge mode and I am assigned a static IP by the Airtel folks.
Looking for some Cisco pundits for their thoughts on how to go about doing this.

The idea would be to completely do away with the Beetel box and have the link directly terminated on the Cisco box.
 
1. Create DHCP POOL
2. Configure Interfaces
3. Create Dialer
4. Configure PAT
5. Add default route

Code:
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool LOCAL
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.1.1
!
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface FastEthernet1
ip address 192.168.1.1 255.255.255.0
no shut
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.32 point-to-point
pvc 1/32
pppoe-client dial-pool-number 1
!
interface Dialer1
encapsulation ppp
ip address STATICIP.GIVEN.BY.ISP 255.255.255.255
ip nat outside
ip mtu 1492
ppp authentication pap callin
dialer pool 1
dialer-group 1
ppp chap hostname AIRTELUSERNAME
ppp pap sent-username AIRTELPASSWORD
!
ip nat inside source interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 ISP.NEXT.HOP.IP
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!

Hope you have configured rest of the security and hardening settings? WAN facing ACLs, line vty restrictions, line con, NTP, etc.

PS: all of the LAN facing interfaces can be made part of a BVI group (just how all those LAN ports of a home wifi router behave)
 
I had used this 861 way back in 2004. It is rock solid router. As pointed out by rock follow the config and you should be good to go. Just setup access list as per your needs.
 
Thanks Rock! Let me give this is shot over the weekend and get back to you.

1. Create DHCP POOL
2. Configure Interfaces
3. Create Dialer
4. Configure PAT
5. Add default route

Code:
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool LOCAL
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.1.1
!
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface FastEthernet1
ip address 192.168.1.1 255.255.255.0
no shut
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.32 point-to-point
pvc 1/32
pppoe-client dial-pool-number 1
!
interface Dialer1
encapsulation ppp
ip address STATICIP.GIVEN.BY.ISP 255.255.255.255
ip nat outside
ip mtu 1492
ppp authentication pap callin
dialer pool 1
dialer-group 1
ppp chap hostname AIRTELUSERNAME
ppp pap sent-username AIRTELPASSWORD
!
ip nat inside source interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 ISP.NEXT.HOP.IP
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!

Hope you have configured rest of the security and hardening settings? WAN facing ACLs, line vty restrictions, line con, NTP, etc.

PS: all of the LAN facing interfaces can be made part of a BVI group (just how all those LAN ports of a home wifi router behave)
 
Back
Top