WTB Ipad


madmaniac

Well-Known Member
Adept
Feedback: 5 / 0 / 0
I'm looking to buy a used ipad. Doesn't need to be the latest one. Even a ipad mini will work. It's to run a the Loyverse app so should run ios 8 or later.
 

Top