Storage Solutions Old hardware SSD boot issues


I have this decade old hardware.
Amd athlon x4 620/ TA790GX A3+ mobo./ 12gb ram/win10 pro with of course a basic bios (non uefi)

I cloned the hdd to ssd and tried booting via ssd but it simply stucks after bios screen.

I tried variety of storage options in bios and also all ports but seems ssd isn't supported on this mobo or what unsure.

Ssd does get detected on all channels/ports and it works great in other older i7 machine.


Here's a clean pic


I'm able to boot via HDD but not SSD. Is it due to EFI partition?
Will converting the sdd from gpt to mbr do the trick?
Last edited:


Clone will only work when using same system but changing/upgrading HDD to SSD. If you need to boot this on **dis-similar** hardware, you would need to first sysprep the machine. Simple clone sometimes worked in winxp days, but now MS ensures your licence will be invalid when used on different hardware. Procedure is Sysprep>Capture Image>Deploy to new HW. A different platform might use a completely different HAL and thus ur system will fail to boot. Sysprep with the **Generalise** and **OOBE** option ensures OOBE runs and detects the HAL of the new hardware. I would say do in this order 1. clone disk 2. Disconnect original HDD. 3. Boot clone on the **same** hardware 4. Run sysprep with oobe and generalise, shutdown when done. 5. Unplug the cloned and now syspreped disk and plug it in the new platform/hardware. 6 Boot.
Last edited: