Pc not turning on after applying thermal paste


karthik nair

New Member
Disciple
I just today on 16/7/2020 applied thermal paste on my cpu I kept the computer on ground and sat in the floor to apply the thermal compound but after doing all the usual checking and placing the cooler tight the pc is not turning on still(no signs of life). nothing is turning on even the light on my motherboard is not turning on.

My pc specs:-
1.)Intel e1260 dual core processor @1.8ghz
2.) 2gb DDR2 800mhz single channel ram 800mhz
3.) gigabyte ga-945-gcm-s2l motherboard
4.)500gb ide drive
Plzzz help I am a student and I want my computer back urgently for study purpose.

Thanks in advance
 

nRiTeCh

Well-Known Member
Veteran
Is this a new machine or older?
What do you mean by "placing the cooler tight"
Just try connecting your mobo+cpu+psu outside the cabinet and post the result.
 

mk76

Well-Known Member
Adept
-- Did you turn the (PSU) back switch on ???

if yes, Troubleshoot step by step
- Remove the head sink and check if you mistakenly applied too much of the paste. If it's visible outside CPU boundary, clean it thoroughly
- Check if the CPU and 24pin ATX connector are in place securely
- remove all peripherals - hdd, sdd, pcie card , gpu
- try to boot .. Do you hear post beeps ( assuming you have motherboard spk connected )
- if not, remove ram and try to boot and listen to post beeps
- if not, take the cpu,ram,mobo to somewhere where you can test them one by one for fault
- if all ok , check your PSU
 

karthik nair

New Member
Disciple
But happens is like when I turn on the main switch for the pc which on my wall socket near to it (by the way the power supply doesn't have any power switch it's a cheap one.) NOTHING happens literally only my monitor turns on before applying thermal paste when iturn on the main switch a green light on the motherboard always lit up as a sign it's getting power.But now nothing is happening as if the pc is dead.what should I do now??????
 

NAV33N

Well-Known Member
Adept
But happens is like when I turn on the main switch for the pc which on my wall socket near to it (by the way the power supply doesn't have any power switch it's a cheap one.) NOTHING happens literally only my monitor turns on before applying thermal paste when iturn on the main switch a green light on the motherboard always lit up as a sign it's getting power.But now nothing is happening as if the pc is dead.what should I do now??????

Double check the front panel io connectors, it might be possible that power switch connection has been disconnected. (Refer attachment)
Also download your motherboard manual from this link https://www.gigabyte.com/Motherboard/GA-945GCM-S2L-rev-10/support#support-dl

If that doesn't work then can you post a clear picture of the the PC with side panel removed?
 

Attachments

  • Screenshot_2020-07-17-10-45-40-399_com.google.android.apps.docs.jpg
    Screenshot_2020-07-17-10-45-40-399_com.google.android.apps.docs.jpg
    174.7 KB · Views: 32

karthik nair

New Member
Disciple
So I did all the possible things even today morning I just reseated the cpu and applied a new coat of thermal paste and rechecked all the connections but when I turn on the main power switch (which is on the wall socket to which the power supply cord is connected) nothing shows up no signs of life.even before applying thermal paste the motherboard light used to be lit when the main switch is turned on.plzz tell me what should I do????
 

CapriAnupam

Well-Known Member
Adept
The fact that the motherboard light is not turning on..indicates that there might be a problem with the PSU or the cable connections from the PSU to the motherboard. I hope you know how to assemble or disassemble a motherboard and have done it before.

Have you connected the power cables from the PSU to the motherboard properly and correctly?

If yes, there the PSU might have gone bad. As you say, the power switch is faulty... that might be the reason.

If you can arrange for another PSU from your friend or have an old PSU, test with it.

First of all, the motherboard light should come on.. that means power from PSU is coming on, and then other components can be tested.
 

Top