Sennheiser HD 598 SE Over-Ear Headphones (Black) @ 6500

booo

BA BA BA BABANANA
Skilled
Feedback: 8 / 0 / 0
I hope your ears are fine and nothing bad happened.
got my head buzzed for a while due to sudden boing boing sound in my left ear.

Btw, A great update, I disconnected the headset and plugged it to my phone. the headset seems to be perfectly fine :D

does that mean the sound card is gone? I will disconnect and reconnect it tomorrow and see. I have a Creative Sound Blaster Z. never liked it anyway due to the software. so seems the loss may have been reduced from 250 to 100 dollars :D yeah, I bought it for 250 AUD[DOUBLEPOST=1449211482][/DOUBLEPOST]
Sound card.png

looks like creative definitely did not test it throughly as explained in this video.
 
Last edited:

Chaos

Skilled
Feedback: 4 / 0 / 0
got my head buzzed for a while due to sudden boing boing sound in my left ear.

Btw, A great update, I disconnected the headset and plugged it to my phone. the headset seems to be perfectly fine :D

does that mean the sound card is gone? I will disconnect and reconnect it tomorrow and see. I have a Creative Sound Blaster Z. never liked it anyway due to the software. so seems the loss may have been reduced from 250 to 100 dollars :D yeah, I bought it for 250 AUD

Reseat the card. I've seen my Xonar DX lose one channel once in a while. Simply reseating the card fixes it.
 

hector19

| Crafted for Gaming |
Adept
Feedback: 4 / 0 / 0
word of caution... IDK if its my bad luck...
but here's what happened!!!! My First headphones arrived in pristine condition, I plugged it into my Fiio E10K & I almost puked listening to it, My god drivers are DOA sounds like cheap one!
crackling noise in right side at 50% of volume, to rule out any DAC foul play tested my DAC again with other pair of drivers ( ATHM50 & Soundmagic P11 ) they sound fine,burned in,no luck... so requested a RMA everything went smooth
replacement arrived today ALAS... it is even worse.. both sides are broken !!! I mean WTF? 2 times in a row? are they selling a broken manufacturing mistake lot at such cheap price?
 

Arkon

Disciple
Feedback: 0 / 0 / 0
word of caution... IDK if its my bad luck...
but here's what happened!!!! My First headphones arrived in pristine condition, I plugged it into my Fiio E10K & I almost puked listening to it, My god drivers are DOA sounds like cheap one!
crackling noise in right side at 50% of volume, to rule out any DAC foul play tested my DAC again with other pair of drivers ( ATHM50 & Soundmagic P11 ) they sound fine,burned in,no luck... so requested a RMA everything went smooth
replacement arrived today ALAS... it is even worse.. both sides are broken !!! I mean WTF? 2 times in a row? are they selling a broken manufacturing mistake lot at such cheap price?

Try testing your headphone with a sinewave sweep here: http://www.audiocheck.net/testtones_sinesweep20-20k.php

I hear a smooth sweep of sound, single tone, no crackling or anything. Let me know what you hear.

Also you could try these tests: http://www.audiocheck.net/soundtests_headphones.php
 

hector19

| Crafted for Gaming |
Adept
Feedback: 4 / 0 / 0
Top