Monitors Very strange monitor issue


deepakvrao

Well-Known Member
Adept
I have a Dell Ultrasharp which is about 4 years old. Out of warranty, so Dell have refused even to do a paid service.

It's a monitor that I use in my operation theatre. It suddenly stopped showing the input. This is with an HDMI cable from my operating camera to the monitor HDMI. Cable is fine as when I connect another monitor, it works just fine.

Strange thing is that when I connect my age old Vaio with a HDMI cable it works. Does not work with my Lenovo or Macbook. It's NOT the hub issue, as that hub works with other monitors, and this Dell does not show the signal even with a direct HDMI to HDMI cable [same one used with the Vaio, when connected to my camera as source].

Any ideas?

Oh and another issue is that none of the on screen menu buttons work either, but how can it display a signal from one source but not another?
20191014_144538.jpg
20191014_144455.jpg
 
Last edited:

nRiTeCh

Well-Known Member
Veteran
Can you try with another hdmi cable and not the camera provided?
Menu buttons is fine if not working as you can use dell utilities to access menu related settings from windows.
May also be some issue with hdmi ver. compatibility with your mac and lenovo though it should work 99.99%. Else check the video settings in these. You might need to toggle between seems settings there.
 

deepakvrao

Well-Known Member
Adept
Can you try with another hdmi cable and not the camera provided?
Menu buttons is fine if not working as you can use dell utilities to access menu related settings from windows.
May also be some issue with hdmi ver. compatibility with your mac and lenovo though it should work 99.99%. Else check the video settings in these. You might need to toggle between seems settings there.

Tried with 3 HDMI cables. All work from Vaio to the 27" monitor. And all cables work with my Lenovo, Macbook and camera to the other 24 Dell. But from these three to the 27 Dell no display. Cannot explain this at all.
 

puns

Well-Known Member
Staff member
when its working with your laptop, reinstall the monitor drivers. maybe go back to an older version if possible.
 

Top