CPU/Mobo Solved: Ryzen 5 3600 with Asus TUF B450-Plus Gaming mobo not starting


nikrusty

Well-Known Member
Adept
So I built a Ryzen 5 3600 with Asus TUF B450-Plus Gaming mobo, 16GB Corsair RAM for myself in March 2020 right before the lockdowns. I paired it with my old NVIDIA 1060 3GB and SMPS Corsair VS650.

Ever since monsoon started here in Mumbai, my comp started to act up. It just wouldn't start no matter what I did
- The fancy LED vanity lights in the mobo would start as soon as power was on
- The processor fan wouldn't spin- Pulled out all components, tried one by one
- Removed the front panel power, reset switches to check- Even got a new Antec VP550 SMPS thinking that was the problem and nope it just wouldn't start.

Finally fed up, I thought maybe it is a moisture caused issue, so I actually put my comp out in the sun for 30 mins (as I have no hairdryer and vacuum cleaner doesn't help) and voila it worked after that! Lol, Sundried PC...that's got to a first!
- Everything works well, in games and I've been running for days without shutdown
- Comp restarts fine, as soon as I shut down and wait for 15-20 mins, the comp just doesn't start, no fans spin
- Then I started to use a 200W bulb which gives of a lot of heat and keep it at the rear of the PC. (Ensuring it doesn't touch any wires etc as it would melt them). And the PC starts after 30 mins of doing that.

So my question, what is the problem? The SMPS is ruled out as I checked with another comp and both SMPS work immediately. It seems to be an Asus B450-Plus Gaming mobo.

I just updated the BIOS to the latest as ppl mentioned similar issues with BIOS. But I never had this issue initially for a few months. Nevertheless, new BIOS install, drivers fully updated of mobo too from Asus website in Oct 2020

My conclusion:-It is a moisture issue with the mobo as heat seems to help it to start. Go to the service centre then I guess. Never had such a weird issue like this.
Mobo page https://www.asus.com/Motherboards/TUF-B450-PLUS-GAMING/

My attempts at reviving and yes it was successful. I just shouldn't ever shut down. Though if lights go, back to the weird technique.
 

Attachments

  • ba37eb77-f695-4320-b810-36b924f875c7.jpg
    ba37eb77-f695-4320-b810-36b924f875c7.jpg
    229.3 KB · Views: 42
  • ea169ac0-dc9c-4b52-bd24-c91bf8d1455c.jpg
    ea169ac0-dc9c-4b52-bd24-c91bf8d1455c.jpg
    184.8 KB · Views: 33
Last edited:

nikrusty

Well-Known Member
Adept
Solved - Reseating the proccy worked! I'm amazed that it did. The comp has started multiple times from cold boot without any issues. Last night I turned it off and switched it on in the morning, 8 hrs have passed. She started up like a charm. Though I'm going to wait and watch for the next few days.


So moisture was causing bad connection basically. And the heating technique that I used was somehow helping to get the connection back? From the CPU to mobo? Sounds weird doesn't it!
 

Top