Ssd not showing up in BIOS


Devanno

New Member
Recruit
Hello everybody,
I have installed a new SSD to my laptop through a caddy at first it appeared in BIOS boot priorities, then i have installed a clean install of windows 10 to the SSD as to dual boot with two vesions of win 10 on my laptop one on the main HDD and the other on SSD but when i opened the bios again the ssd disapeared from the bios priorities under hard drives.

Solutions i have tried:
  1. I formatted the SSD drive, and i converted it to GPT partition table then to MBR partition table and it didn't show up with the both.
  2. I have searched for bios upgrade but i have the latest version.
  3. I have loaded default bios settings.
  4. I tried to boot in recovery mode to the uefi settings but i have legacy bios version.
  5. I deleted the ssd partition to be unallocated space.
  6. I have checked for SSD drivers updates.
Nothing from this solutions worked and the main reason i have installed this SSD is to boot from it so please i need help to solve this as it don't show up in bios and i can't boot from it.

Laptop model: Dell XPS l502x
BIOS version: A12
SSD :Kingston 120GB a400
 
Last edited:

Top