*** The Anti-Showoff Thread ***

How did you setup the redundancy between the two ? Also are they connected to the network on wifi ?

They're connected by ethernet, the redundacy/failover is handled by the router — Mikrotik routers have a tool called netwatch, which can trigger a script to run when a device becomes online or offline, I have it set to update DNS servers. This coupled with a DHCP lease time of 60 seconds keeps the devices on the network updated with whatever DNS servers are currently online.


Here are the scripts, with sensitive information redacted. They're pretty much human readable. The UP script:

C-like:
:local activedns [:toarray ""]
:local notifydns
:if ([/ping 192.168.254.1 count=1]=0) do={
:set notifydns "AdBlockerOne is offline"
} else={
:set activedns ($activedns, "192.168.254.1")
:set notifydns "AdBlockerOne is online"
}
:if ([/ping 192.168.254.2 count=1]=0) do={
:set notifydns ($notifydns."%0AAdBlockerTwo is offline")
} else={
:set activedns ($activedns, "192.168.254.2")
:set notifydns ($notifydns."%0AAdBlockerTwo is online")
}
:if ([/ping 192.168.254.3 count=1]=0) do={
:set notifydns ($notifydns."%0AAdBlockerBM3 is offline")
} else={
:set activedns ($activedns, "192.168.254.3")
:set notifydns ($notifydns."%0AAdBlockerBM3 is online")
}
:if ([/ping 192.168.254.4 count=1]=0) do={
:set notifydns ($notifydns."%0AAdBlockerBM4 is offline")
} else={
:set activedns ($activedns, "192.168.254.4")
:set notifydns ($notifydns."%0AAdBlockerBM4 is online")
}
[/ip dns set servers=$activedns]
[/tool fetch url="https://api.telegram.org/botX:X/sendMessage\?chat_id=X&disable_notification=true&text=$notifydns" keep-result=no]

The DOWN script is identical but with these additional commands:

C-like:
:if ([:len $activedns]=0) do={
:set activedns ($activedns, "1.1.1.1")
:set notifydns ($notifydns."%0APublic DNS activated")
}
[/tool fetch url="https://api.telegram.org/botY:Y/sendMessage\?chat_id=Y&text=Network configuration invalid,%0Aautomatic reset in 60 seconds." keep-result=no]

Both scripts are active across all of the adblockers. They're hardcoded for now as I refine my networking setup, the proper way to do it is probably a loop with array/variables.

AdBlockerOne and AdBlockerTwo are proxmox VM's on a host that I've turned off because of the current heatwave. BM3 and BM4 are these two adblockers on 'bare metal'.

These scripts also send telegram notifications, I have two groups/channels set up for these kind notifications. The first one has more technical information and it's primarily for myself:

photo_2023-06-03 18.28.12.jpeg

The other is for family, primarily to let them know if there are issues with the wifi/internet:

photo_2023-06-03 18.28.10.jpeg

The 'automatic reset' is the DHCP refresh time that'll push out whichever DNS servers are active.
 
Last edited:
Anyone running a secondary linux box for compute? It's something I'm considering since it feels like I'm always at the limit of what's possible with Apple's M1.

want need more cores (all four performance cores maxed out for the last few hours):

Screen Shot 2023-07-23 at 12.01.23 AM (2).png

love the file size optimizations of Google's Guetzli jpeg encoder, don't love the speed
 
I was watching a movie yesterday (Thelma; mini-review here) and was trying to think of a way to use my Asus Flow laptop (which is what was connected to the TV via a HDMI to type-C convertor) at the same time. It's a very old Vizio TV whose USB input can only playback images, so that was out. Other options I considered:
  • Didn't want to use my current phone (S23 Ultra) because I would have to disconnect it if I got a phone call
  • Then I tried my iPad, but turns out that the iPad Mini 6 doesn't support Stage Manager :)mad: ffs Apple)
  • Acer Helios gaming laptop that otherwise almost permanently stays on my desk, but that would be cumbersome to move around every now ans then plus; not to mention it has terrible battery life
But then I remembered that I have my smashed S22 Ultra in my drawer! It got into its current state thanks to a minor bicycling accident about a year ago (thankfully, no injuries) which sent it flying out of my pocket and crushed and dragged under my own bike's front wheel as I frantically applied brakes. It is smashed beyond repair (at least for a price that would make sense) but the type-C port was still working. Amazingly, it still responded to touch commands on the lower third of the screen where the glass is intact, so I was able to use Dex for Windows (since it requires tapping "Start" on the phone unlike when connecting directly to a display) to get all my data and delete it since otherwise there was no reliable way of unlocking the screen. I didn't reset the phone since I was unsure whether HDMI passthrough would work on a freshly reset device even if I were to theoretically connect a mouse and keyboard using a dongle/hub.

Now, about 8-10 months since I last powered it on, I decided to put it to some use by using Dex to load movies on it and using it as a media player connected to a TV! I connected it to my laptop and simply drag and dropped the movie folders from the File Explorer window to the File Manager app and voila!
Connected a mouse and keyboard via bluetooth and it's a great experience. Planning to use it as a jugaad NAS + streaming + torrenting device of sorts since the 256GB storage is actually a pretty good amount lol
Also, as much as I want to, will not be playing any games/emulators on it since I am not sure how well it can dissipate heat due to the damage

I also have an old Poco X3 (and even that has HDMI passthrough, although no desktop mode) whose USB port no longer does any data transfer (works only for charging) and I used it as a NAS for a short while by loading movies via microSD card. However, I quickly stopped using it as NAS since I didn't want to leave it plugged in and charged to 100% all the time and risk a spicy pillow (aka bulging battery). Moral of the story is that you should put your old devices to use instead of buying a new one; and Android phones can be surprisingly more capable for basic stuff like a streaming/media box.
 

Attachments

  • 1722200256544.jpeg
    1722200256544.jpeg
    333.8 KB · Views: 126
Last edited:
I still have an analog portable B/W CRT TV 5" . Purchased around 1999. Still works.
While testing I observed lots of interference from electrical equipments especially LED tubelights. Went to terrace and powered it with a 12v battery to avoid electrical noises.
Discovered that DD National no longer exists on analog. Lucky enough to catch BTV signal (Bangladesh).
 

Attachments

  • WhatsApp Image 2024-08-08 at 10.11.43 PM.jpeg
    WhatsApp Image 2024-08-08 at 10.11.43 PM.jpeg
    87.4 KB · Views: 86
I still have an analog portable B/W CRT TV 5" . Purchased around 1999. Still works.
While testing I observed lots of interference from electrical equipments especially LED tubelights. Went to terrace and powered it with a 12v battery to avoid electrical noises.
Discovered that DD National no longer exists on analog. Lucky enough to catch BTV signal (Bangladesh).
Yes, all TV stations are digital now.
And you possess a tiny gem. Take care of it.
 
In an attempt to give some life to a recently resurrected PC of mine, I went and bought the cheapest SSD I could find. Which was this Lexar for Rs 1k:-
LexarSSD.jpg


Its a DRAM-less QLC drive which as far as SSDs go is kind of the worst. But even still, compared to the HDD that I was previously using this is a night and day difference.

Old Seagate 7200rpm HDD:-
Seagate 7200 HDD.jpg


New Lexar SSD:-
Lexar NQ100 SSD.jpg
 
In an attempt to give some life to a recently resurrected PC of mine, I went and bought the cheapest SSD I could find. Which was this Lexar for Rs 1k:-
View attachment 211592

Its a DRAM-less QLC drive which as far as SSDs go is kind of the worst. But even still, compared to the HDD that I was previously using this is a night and day difference.

Old Seagate 7200rpm HDD:-
View attachment 211593

New Lexar SSD:-
View attachment 211594
where did you find it for 1K?
 
After the weighted school bags started getting unbalanced owing to weights being on only one side, took the help of a welder to make an "adjustable weighted vest" for weighted calisthenics I got into during the pandemic. Cost - Rs 500. Sewed the velcro straps myself. Hundreds of dips, pullups, pushups done during the pandemic using these.
 

Attachments

  • hmgym.jpeg
    hmgym.jpeg
    458.7 KB · Views: 66
  • hmgym2.jpg
    hmgym2.jpg
    101.3 KB · Views: 67
In an attempt to give some life to a recently resurrected PC of mine, I went and bought the cheapest SSD I could find. Which was this Lexar for Rs 1k:-
View attachment 211592

Its a DRAM-less QLC drive which as far as SSDs go is kind of the worst. But even still, compared to the HDD that I was previously using this is a night and day difference.

I like the Lexar drives as inexpensive boot drives for vm hosts. They used to be available on Amazon a couple of years ago.

It's mostly a nostalgia purchase for me, Lexar products used to be crazy high-end and expensive, back when SanDisk was the cheaper option, ha. Lexar was Verbatim of the early 2000s. Those brands commanded such a premium and they were so good, everything from packaging to manuals to warranty was exceptional with them.

These days they're both just a sticker/label on mass produced stuff.

Like other inexpensive drives, these Lexar units have an activity/power led on the PCB that's visible through a screw hole, hilarious.
 
Back
Top