Nokia G-140W-F bridge mode?

I had the same issue and I figured out how to solve it. I have Airtel Nokia modem G-140W-F.

Here's what I did:

0. Login to the web interface of the Airtel's Nokia ONT device
1. Backup your configuration by navigating to Maintenance-->Backup and Restore-->Export Config File;
1a. This will be useful in case you mess up stuff in your configuration and want to restore things back.
2. Navigate to "Network-->WAN"; delete "?_TR069_INTERNET_R_VID_100" entry.
3. Navigate to "Network-->LAN"; Setup one of the LAN ports to "Bridge Mode"; you can configure all of them to "Bridge Mode" as well - your choice; the Nokia device will reboot at this point for the changes to take effect.
3a. The LAN port you set to "Bridge Mode" should be the port you want to connect your downstream home router (where you run the PPPoE authentication).
4. Configure your downstream home router with the ISP's PPPoE username and password.
5. Airtel's Nokia modem bridges the PPPoE packets from the PON interface to the selected Ethernet LAN port on "VLAN 100" (yes, that's correct; I figured this out the hard way - it doesn't strip off the vlan headers before bridging it to the LAN port; neither does it support any option to strip the VLAN headers before bridging). So you need to configure your downstream home router's port on VLAN 100. If your home router does not support VLANs then, BUMMER, you cannot use bridge mode! :banghead: (shame on Airtel & Nokia :mad: to have overlooked this important aspect - b'coz a lot of home routers do NOT support VLANs; fortunately mine does, because I use OpenWRT firmware).
6. Configure your downstream home router's WAN port (that connects to the Nokia router) on VLAN 100 (tagged; not untagged)
7. That's it. Your PPPoE authentication should go through and your internet link should be UP and running.

Good luck!

- Anand
 
Last edited:
@tellanand This is great news and i hope other can reproduce it. Couple of questions:
  • Do you mind sharing what port did you select for bridging?
  • Do you have any 'WAN connection' profiles at all?

I spent sometime early in the year to figure this out, but was not successful.

Another downside of the Nokia router is that it does not expose the Voice/SIP settings, and the config file seems to be encrypted.
 
@tellanand This is great news and i hope other can reproduce it. Couple of questions:
  • Do you mind sharing what port did you select for bridging?
  • Do you have any 'WAN connection' profiles at all?

I spent sometime early in the year to figure this out, but was not successful.

Another downside of the Nokia router is that it does not expose the Voice/SIP settings, and the config file seems to be encrypted.

  • I configured LAN ports 3 & 4 in Bridge mode. Left ports 1 & 2 in Routing mode. I have connected my home router to Port 4. But it works on Port 3 also (verified).
  • Can you elaborate what do you mean by "WAN connection" profile? Do you mean on the Nokia router?
Overall, I agree that Nokia router is crappy and pretty dumb. As much as I hate saying it, Huawei router is feature rich.

I did not try to decode the config file - I did not expect it to be encrypted. Really?
 
Last edited:
You mentioned about deleting the existing WAN profile ""?_TR069_INTERNET_R_VID_100". Did you set up anything there after that? It would nice to see a screenshot of your WAN page and ports page.

Yes, it is pretty shabby that Nokia is encrypting the config file. Huawei also does it on some routers, but thankfully not for this.
Post automatically merged:

@tellanand I tried to give your instructions a go.

I configured port 3 on openwrt (tplink archer C7) for VLAN100. Here is the openwrt config:

Code:
#/etc/config/network

config switch_vlan                   
        option device 'switch0'      
        option vlan '5'              
        option ports '4 6t'          
        option vid '100'

config interface 'WAN2'
        option ifname 'eth0.100'
        option proto 'pppoe'
        option password 'blahblah'
        option ipv6 'auto'
        option metric '30'
        option username 'blahblah'


Next, i changed ports 3 and 4 on the nokia router to bridge mode.
1595476823317.png



Port 3 on the Nokia router is connected to openwrt. Unfortunately, the pppoe interface does not come up on the openwrt router.
Code:
Thu Jul 23 09:30:14 2020 daemon.notice netifd: Interface 'WAN2' is enabled
Thu Jul 23 09:30:14 2020 daemon.notice netifd: Interface 'WAN2' is setting up now
Thu Jul 23 09:30:14 2020 daemon.err insmod: module is already loaded - slhc
Thu Jul 23 09:30:14 2020 daemon.err insmod: module is already loaded - ppp_generic
Thu Jul 23 09:30:14 2020 daemon.err insmod: module is already loaded - pppox
Thu Jul 23 09:30:14 2020 daemon.err insmod: module is already loaded - pppoe
Thu Jul 23 09:30:14 2020 daemon.info pppd[11520]: Plugin rp-pppoe.so loaded.
Thu Jul 23 09:30:14 2020 daemon.info pppd[11520]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Jul 23 09:30:14 2020 daemon.notice pppd[11520]: pppd 2.4.7 started by root, uid 0
Thu Jul 23 09:30:29 2020 daemon.warn pppd[11520]: Timeout waiting for PADO packets
Thu Jul 23 09:30:29 2020 daemon.err pppd[11520]: Unable to complete PPPoE Discovery
Thu Jul 23 09:30:29 2020 daemon.info pppd[11520]: Exit.
 

Attachments

  • 1595476895307.png
    1595476895307.png
    16.9 KB · Views: 426
Last edited:
@rajil.s: I use LAN Port4 on my OpenWRT router (which maps to number index # 1 in OpenWRT network switch config). Here's my /etc/config/network (I use TP-LINK Archer C2600)

Rich (BB code):
config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '100'
        option ports '0t 1t'

config interface 'wana'
        option ifname 'eth0.100'
        option proto 'pppoe'
        option password '*********'
        option ipv6 'auto'
        option metric '10'
        option username '*********'

I configured port 3 on openwrt (tplink archer C7) for VLAN100.

In your network config, I see that you have configured port 4 as untagged. Like I said, it should be a tagged VLAN port. It should work if you change '4' to '4t' in your network config - see below:

Rich (BB code):
config switch_vlan
        option device 'switch0'
        option vlan '5'   
        option ports '4 4t 6t'
        option vid '100'

You mentioned about deleting the existing WAN profile ""?_TR069_INTERNET_R_VID_100". Did you set up anything there after that? It would nice to see a screenshot of your WAN page and ports page.

I did not do anything after deleting the WAN interface. Your snapshot looks exactly like mine - so there is no point in sharing my screenshot. My sense is, if you fix your OpenWRT port 4's switch config to "tagged" - it will start to work.

Give it a try and let me know.
 
Last edited:
@telland, Thanks for pointing out the error in my port config. I modified it to the following

Code:
config switch_vlan
        option device 'switch0'
        option vlan '5'
        option vid '100'
        option ports '4t 6t'

config interface 'WAN2'
        option ifname 'eth0.100'
        option proto 'pppoe'
        option password 'blahblah'
        option ipv6 'auto'
        option metric '30'
        option username 'blahblah'

The physical LAN port 3 on tp link archer C7 is internally wired to internal port 4,
archerc7v2-switch-diagram.png


Unfortunately, the PPP interface on openwrt is still not coming up.

Also, I have noticed that the bridged ports on the Nokia router (Port 3 and 4) have their LED switch off sometimes. I suspect it has something to do with whether the WAN profile on the Nokia router is enabled or not.

At this point I am trying to figure out what is different in my setup versus yours. Are you using any other port on the Nokia router? I have a cable plugged into Port 1 of the Nokia router which is setup into routing mode. This allows me to access the web-interface of the Nokia router.

Also, did you have any discussion with Airtel on this? Apparently for some people Airtel backend does their magic and enable bridging on Port 4. I suspect they might be untagging the port rather keeping it tagged as you pointed out.
 
@rajil.s - sorry to hear that it still does not work.

Could you share your OpenWRT /etc/config/network ? I can help review to see if something is amiss. Please also share your network topology (to aid my review).

Also, I have noticed that the bridged ports on the Nokia router (Port 3 and 4) have their LED switch off sometimes. I suspect it has something to do with whether the WAN profile on the Nokia router is enabled or not.

In my Nokia ONT the Port 4 (where I have connected my OpenWRT router) blinks (indicating traffic activity) and never goes off unless I pull out cable from port 4. I dont have anything else connected on any other Ethernet port. Like I said before, I have not done anything other than deleting the WAN data profile (on Nokia router) and configuring ports 3 and 4 in bridge mode (this is what was also suggested by Airtel's technical team - though they did not say anything about the VLANs being bridged also).

I suspect that the LAN LED going off may have something to do with the LAN port status on your OpenWRT router - might be worth checking if something is toggling Ethernet status on your OpenWRT router (or the Ethernet cable itself; sorry for being paranoid about cable, just ruling things out)???

For what it's worth I'm attaching my Nokia router config here for your reference.

Nokia-LAN Config.jpg
Nokia-LAN Status.jpg

Nokia-Back.jpg
Nokia-Front.jpg


Here are details on my OpenWRT router and configuration:

1. TP-Link Archer C2600 Port Mapping (ref: https://openwrt.org/toh/tp-link/tp-link_archer_c2600_v1):

PortSwitch port
Internet (WAN)5
LAN 14
LAN 23
LAN 32
LAN 41
GMII0 (marked as CPU) Switch0 CPU Port eth0
6 Switch0 CPU Port eth1

2. Here is my /etc/config/network; please note that I have two WAN connections - one from Hathway (Port5, Untagged VLAN) and one from Airtel (Port1, tagged VLAN). I run a load-balancer over the two WAN interfaces (that's just FYI, not relevant to this discussion).

Rich (BB code):
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

# VLAN 1 is Home LocalLAN
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 6t 4 3 2'

# VLAN 2 is HATHWAY; Untagged (fortunately HATHWAY ONT does not tag packets in bridge mode)
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '6t 5'

# VLAN 100 is AIRTEL; tagged (unfortunately AIRTEL ONT VLAN tags packets in bridge mode)
config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '100'
        option ports '0t 1t'

config interface 'LocalLAN'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        list dns '8.8.8.8'
        list dns '1.1.1.1'
        option ipaddr '192.168.1.1'
        option type 'bridge'

# HATHWAY WAN interface
config interface 'wanh'
        option ifname 'eth1.2'
        option proto 'pppoe'
        option password '*****'
        option service 'HATHWAY'
        option ipv6 'auto'
        option username '*****'
        option metric '20'

# AIRTEL WAN interface
config interface 'wana'
        option ifname 'eth0.100'
        option proto 'pppoe'
        option password '*****'
        option ipv6 'auto'
        option metric '10'
        option username '*****'

At this point I am trying to figure out what is different in my setup versus yours. Are you using any other port on the Nokia router? I have a cable plugged into Port 1 of the Nokia router which is setup into routing mode. This allows me to access the web-interface of the Nokia router.

I have shared my config above. Review it to see if it helps. I don't have anything else plugged into my Nokia. If I have to configure my Nokia router, I login through WiFi - I've kept WiFi 5G radio ON for this purpose - though I cannot access internet through Nokia WiFi (b'coz the WAN is bridged); I just use it to configure the Nokia router when I need it.

Also, did you have any discussion with Airtel on this? Apparently for some people Airtel backend does their magic and enable bridging on Port 4. I suspect they might be untagging the port rather keeping it tagged as you pointed out.

I did raise a ticket with Airtel and discussed with their technical folks. But nothing came out of it - those guys did not tell me anything useful, other than how to configure Nokia in bridge mode (they did not tell me that the Nokia bridges with the VLAN tags). Like I said earlier, I figured this out the hard way on my own.

Here's what I did to figure it out - I suggest you try it as well:

1. Connect Nokia router Port 4 (configured as bridged interface) directly to your PC (Windows 10)
2. Configure VLAN100 on PC's Ethernet port (this is not straight forward. I had to dig around a bit, google for it to figure out how to configure VLAN on Windows 10; I have Intel Ethernet NIC - so I had to download "Intel ProSET Adapter Configuration Utility" to configure VLANs on my Windows 10 PC).
2a. Alternatively, if you have a Linux machine, you can configure VLAN on the Ethernet interface as well.
3. Then I configured a "Dial-up" interface - i.e. PPPoE on the VLAN interface (entered Airtel's PPPoE username and password). I got this configuration working first before I replicated the same into OpenWRT.

You could try the same and see if you are able to troubleshoot better!

Good luck man! Keep me posted!
 
Last edited:
@tellanand, Thanks for the detailed reply. The difference i can see is that
- I only disabled the default WAN profile whereas you deleted it
- I have a cable from Port 1 of Nokia router to Openwrt which i use to control Nokia router and also routing (before looking bridging)

I was hoping not to delete the profile since there is a landline connected as well. If the exported config does not have the SIP details, than my family is going to be upset :)

Here is my openwrt config at the moment. I am load balancing with ACT and Airtel, and also have a separate vlan for guest network.

Code:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf4:cb2a:afad::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

#ACT internet
config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        list dns '8.8.8.8'
        list dns '8.8.4.4'
        option peerdns '0'
        option metric '10'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
       
config switch_vlan                            
        option device 'switch0'               
        option vlan '1'                       
        option vid '1'               
        option ports '0t 3'          
                                     
config switch_vlan                   
        option device 'switch0'      
        option vlan '2'              
        option vid '2'              
        option ports '1 6t'         
                              
config switch_vlan            
        option device 'switch0'
        option vlan '3'       
        option vid '3'        
        option ports '5 6t'   

#Airtel connected to Port1 of Nokia Router
config interface 'wan1'       
        option ifname 'eth0.3'
        option proto 'dhcp'   
        option metric '20'    
        list dns '8.8.8.8'    
        list dns '8.8.4.4'    
        option peerdns '0'    

#Guest network                              
config interface 'guest'      
        option proto 'static' 
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option type 'bridge'         
        option ifname 'eth1.4'       
                                     
config switch_vlan                   
        option device 'switch0'      
        option vlan '4'              
        option vid '4'               
        option ports '0t 2'         
                                       
config switch_vlan                     
        option device 'switch0'        
        option vlan '5'                
        option vid '100'               
        option ports '4t 6t'           

#Airtel connected to Port4 of Nokia Router
config interface 'WAN2'                
        option ifname 'eth0.100'       
        option proto 'pppoe'           
        option password 'blahblah'   
        option ipv6 'auto'             
        option metric '30'             
        option username 'blahblah'
 
I was hoping not to delete the profile since there is a landline connected as well. If the exported config does not have the SIP details, than my family is going to be upset :)

I only deleted the WAN data configuration, not the voice. I have a POTS phone connected to the RJ11 socket of the modem. Deleting the data config does not affect my phone line. Not sure if you meant something else.

Btw the Airtel technical team insisted that I should delete the WAN data profile for bridging to work.

Is there a way to connect a SIP phone on the network? That'll be interesting.
 
I made a further attempt at this but was unsuccessful. I used a managed switch, with 1 port tagged to VLAN 100 and another untagged VLAN 100. Setup a PPP on a computer connected to the untagged port. And there was nothing.

A factory reset also did not help. Somehow i am starting to believe that Airtel did help you insomeway at the back end.

"Btw the Airtel technical team insisted that I should delete the WAN data profile for bridging to work." I did see some evidence of this. It seems that when a profile is defined, it turns off the bridged NICs (LEDs off). When the profile is deleted the bridged NICs do stay Green.

Also, i can confirm that the Voice config was retained when i imported the config.cfg.

Is there a way to connect a SIP phone on the network? That'll be interesting.

Yes, there is actually a SIP client in the router. The HUAWEI router does expose the SIP server and username. However, nobody has yet been able to figure out the SIP password (AIRTEL has not been helpful).
 
Last edited:
@rajil.s - I'm surprised that it's not working for you. And I am pretty sure that the Airtel folks did not make any change at the backend for me (they said it as much - that they cannot make any changes at the backend for the bridge mode).

Having said that, if not already done, for what it's worth, do you want to raise a ticket with Airtel to help you out with the bridge config? Atleast in Chennai, I find Airtel very responsive.

@rajil.s - do you have the SIP profile (sans the password, though)? If yes, could you share?

Will try to see if I can get this. I am on copper, cant recall the router details.

@vivek.krishnan - thanks. SIP profile will be very helpful.
 
Last edited:
@rajil.s - Could you share the SIP profile?
The screenshot with sip details is pasted below. You will need to setup a manual route to reach the sip server since it is an RFC1918 address. The username is your landline number in international format.

Screenshot_20200710_122347.png


The VOICE is on vlan 660. In my router they setup a static ip address (10.117.10.xx). The network details are pasted below
voip.png
 
Last edited:
Thanks. Im sticking with the DMZ option. Can't find the huawei ont anywhere
Even I tried searching for the specific Huawei router, But cant find it anywhere.
How exactly does the DMZ work ? It exposes the 2nd Router (Asus in my case) to the internet and the Asus router gets the public ip and can be configured to login using the PPPOE settings ?
 
Anyone had a luck bridging Nokia g-140w successfully? @rajil.s

Okay, so @tellanand bro. I have done the exact settings like you but it is not working. I have seen your screenshots as well.
Lets skip the Openwrt setup, first I tried to set this up on Windows 8.1 through PPPoe dialer just like you set.

1. I have set Nokia router just like yours. (Delete Wan setting, Same LAN IP's infact etc) and connected LAN from LAN4 to directly my Laptop ethernet port.
2. I have set VLAN to 100 which was in my Nokia router in Network Adapter settings of Windows computer.
3. Created Broadband PPPoe connection and tried connecting but encountered Error 651.
Also I have made the Mac address same so that isn't a issue.

Some of my examinations:
1. When I connect LAN to my laptop, I do not set any ipv4 settings and it automatically assigns 169.x.x.x IP. It doesn't receive any incoming packets as well. How does it work to you when you plug the LAN to windows? What IP it shows to you?
2. Then after inserting LAN, I dial PPPoe on windows and it gives Error 651. But it also gives the same Error 651 when I do not even plug the LAN cable into my laptop?

For whom they got this working, please jump into this thread and help us to get this working.
Also, @tellanand bro, I see you have sent LAN settings screenshots of Nokia router, could you please send the same Pages of WAN? WAN under Network and WAN under status. This is very important.

Thank you!
 
I had the same issue and I figured out how to solve it. I have Airtel Nokia modem G-140W-F.

Here's what I did:

0. Login to the web interface of the Airtel's Nokia ONT device
1. Backup your configuration by navigating to Maintenance-->Backup and Restore-->Export Config File;
1a. This will be useful in case you mess up stuff in your configuration and want to restore things back.
2. Navigate to "Network-->WAN"; delete "?_TR069_INTERNET_R_VID_100" entry.
3. Navigate to "Network-->LAN"; Setup one of the LAN ports to "Bridge Mode"; you can configure all of them to "Bridge Mode" as well - your choice; the Nokia device will reboot at this point for the changes to take effect.
3a. The LAN port you set to "Bridge Mode" should be the port you want to connect your downstream home router (where you run the PPPoE authentication).
4. Configure your downstream home router with the ISP's PPPoE username and password.
5. Airtel's Nokia modem bridges the PPPoE packets from the PON interface to the selected Ethernet LAN port on "VLAN 100" (yes, that's correct; I figured this out the hard way - it doesn't strip off the vlan headers before bridging it to the LAN port; neither does it support any option to strip the VLAN headers before bridging). So you need to configure your downstream home router's port on VLAN 100. If your home router does not support VLANs then, BUMMER, you cannot use bridge mode! :banghead: (shame on Airtel & Nokia :mad: to have overlooked this important aspect - b'coz a lot of home routers do NOT support VLANs; fortunately mine does, because I use OpenWRT firmware).
6. Configure your downstream home router's WAN port (that connects to the Nokia router) on VLAN 100 (tagged; not untagged)
7. That's it. Your PPPoE authentication should go through and your internet link should be UP and running.

Good luck!

- Anand
Wow............
That was absolutely brilliant. I started from step 4, As I had alreadyset the LAN4 to bridged mode. And this method does not even require the NOKIA router to be set to IPOE (from PPPOE).
The DUAL WAN feature on my ASUS RT-AC59U detects the WAN failure after setting this up. Initially it was taking 1 min and 10 seconds to detect the failure, But I changed the "Internet Detection" method on my Asus router to "DNS Probe" and now the detection is as fast as 25 seconds. Thanks a million for sharing this @tellanand .
I dont know how to thank you enough.

1596084720157.jpeg
 
Anyone had a luck bridging Nokia g-140w successfully? @rajil.s

Okay, so @tellanand bro. I have done the exact settings like you but it is not working. I have seen your screenshots as well.
Lets skip the Openwrt setup, first I tried to set this up on Windows 8.1 through PPPoe dialer just like you set.

1. I have set Nokia router just like yours. (Delete Wan setting, Same LAN IP's infact etc) and connected LAN from LAN4 to directly my Laptop ethernet port.
2. I have set VLAN to 100 which was in my Nokia router in Network Adapter settings of Windows computer.
3. Created Broadband PPPoe connection and tried connecting but encountered Error 651.
Also I have made the Mac address same so that isn't a issue.

Some of my examinations:
1. When I connect LAN to my laptop, I do not set any ipv4 settings and it automatically assigns 169.x.x.x IP. It doesn't receive any incoming packets as well. How does it work to you when you plug the LAN to windows? What IP it shows to you?
2. Then after inserting LAN, I dial PPPoe on windows and it gives Error 651. But it also gives the same Error 651 when I do not even plug the LAN cable into my laptop?

For whom they got this working, please jump into this thread and help us to get this working.
Also, @tellanand bro, I see you have sent LAN settings screenshots of Nokia router, could you please send the same Pages of WAN? WAN under Network and WAN under status. This is very important.

Thank you!

@ajeesh_m reply to this please? If you have the knowledge.
 
Back
Top